APIEnv_​NewLibDialID

Instructs the user to select a new library folder in a dialog.

    GSErrCode ACAPI_Environment (
        APIEnv_NewLibDialID,
        char*             defName,
        IO::Location*     newLib
    );

 

Parameters

defName
[in] A pointer to the default name of the new library.
newLib
[out] The file system location of the selected folder.

 

Return Values

NoError
The function completed with success.
APIERR_BADPARS
any of the parameters are nullptr.
APIERR_CANCEL
The user canceled the operation by the cancel button in the dialog.

Remarks

If a library is created or selected, the file specification is returned in the second parameter.

To add a new folder to the active libraries use either the APIEnv_AddLibrariesID or the APIEnv_SetLibrariesID functions.

You may also use directly the base class DG::FolderDialog of the Dialog Manager instead of calling APIEnv_NewLibDialID.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_AddLibrariesID, APIEnv_SetLibrariesID,
ACAPI_Environment, API Functions