APIEnv_​ProtectionDataID

Returns information about the protection data.

    GSErrCode ACAPI_Environment (
        APIEnv_ProtectionDataID,
        API_ProtectionInfo*     protectionInfo,
        GS::UniString*          configurationNumber
    );

 

Parameters

protectionInfo
[in/out] ARCHICAD version data and the parameters of the protection key
configurationNumber
[out]

 

Return Values

NoError
No error occurred.
APIERR_BADPARS
protectionInfo is nullptr.

For other common API errors see the API Errors document.

 

Remarks

You can filter running of your add-on under special ARCHICAD versions such as Full, EDU, PPU, Demo etc. Also you have the possibility to relay on the serial number of the protection key.

The meaning and possible values of the certain fields are described at API_ProtectionInfo.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_ProtectionInfo,
ACAPI_Environment, API Functions