APIEnv_​SetCurrent3DStyleID

Sets an existing style as active.

    GSErrCode ACAPI_Environment (
        APIEnv_SetCurrent3DStyleID,
        GS::UniString*     name
    );

 

Parameters

name
[in] Name of an existing style

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
name is nullptr, or the specified style does not exist.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

See an example at the description of APIEnv_Get3DStyleListID.

 

Requirements

Version: API 20 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API Functions,
APIEnv_Get3DStyleListID,
APIEnv_Get3DStyleID,
APIEnv_Change3DStyleID,
APIEnv_Create3DStyleID,
API_3DStyle