APIEnv_​SetCurrentRenderingSceneID

Sets the current Rendering Scene to the given named Rendering Scene.

    GSErrCode ACAPI_Environment (
        APIEnv_SetCurrentRenderingSceneID,
        const GS::UniString*    newCurrentSceneName
    );

 

Parameters

newCurrentSceneName
[in] The name of the Rendering Scene, which you want to set as the current Scene.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
newCurrentSceneName is nullptr.
APIERR_BADNAME
No named Rendering Scene exists with this name (newCurrentSceneName).
APIERR_GENERAL
Could not set newCurrentSceneName as the current Scene.

For other common API errors see the API Errors document.

 

Remarks

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 18 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, APIEnv_GetRenderingSetsID, APIEnv_ChangeRenderingSetsID, APIEnv_GetRenderingSceneNamesID, APIDo_PhotoRenderID, API Functions