APIEnv_​SetGeoLocationID

Modifies the Location settings of the project.

    GSErrCode ACAPI_Environment (
        APIEnv_SetGeoLocationID,
        API_GeoLocation*    apiGeoLocation
    );

 

Parameters

apiGeoLocation
[in] the Location settings associated with the project

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
apiGeoLocation is nullptr
APIERR_NOTEDITABLE
The Location settings cannot be modified in Teamwork unless it is reserved by the current user.
The function returns this error code also when the Survey Point is locked, and the north angle or the floor plan position in the passed apiGeoLocation differs from the current Survey Point data.

 

Remarks

This function sets the Location settings of the project.

The APIEnv_SetGeoLocationID function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example

API_GeoLocation geoLocation;
ACAPI_Environment (APIEnv_GetGeoLocationID, &geoLocation);
geoLocation.surveyPointPosition.x = -300000;
geoLocation.surveyPointPosition.y = -100000;
geoLocation.surveyPointPosition.z = 100;
ACAPI_Environment (APIEnv_SetGeoLocationID, &geoLocation);  // sets the position of the survey point

 

Requirements

Version: API 25 or later
Header: APIdefs_Environment.h

 

See Also

API_GeoLocation
APIEnv_GetGeoLocationID
APIEnv_GetSurveyPointTransformationID
APIEnv_IsSurveyPointLockedID
ACAPI_Environment
API Functions