APIEnv_​SetLibrariesID

Changes the list of loaded libraries.

    GSErrCode ACAPI_Environment (
        APIEnv_SetLibrariesID,
        const GS::Array<API_LibraryInfo>*     activeLibs
    );

 

Parameters

activeLibs Featuring API 18
the active library list to set

 

Return Values

NoError
The function completed with success.
APIERR_BADPARS
activeLibs is nullptr or size of the internal locations handle is not match to nLib
APIERR_NOTMINE
The project library list is not editable in Teamwork. You need to reserve it first.

 

Remarks

This function is used to reset the list of active libraries of Archicad. The passed library folders will be enumerated. Refer to the API_LibraryInfo for further details.

To get the active libraries use the APIEnv_GetLibrariesID function.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example

See the example of APIEnv_GetLibrariesID.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_LibraryInfo,
APIEnv_AddLibrariesID, APIEnv_GetLibrariesID, APIEnv_ResetLibrariesID,
ACAPI_Environment, API Functions