APIEnv_​SetSurveyPointLockedID

Locks or Unlocks the Survey Point.

    GSErrCode ACAPI_Environment (
        APIEnv_SetSurveyPointLockedID,
        bool*   lockedState
    );

 

Parameters

bool
[in] Lock state of the Survey Point

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter is nullptr

 

Remarks

This function locks or unlocks the Survey Point. Note that this lock affects only the North Angle and the floor plan position of the Survey Point. All the other parameters of the API_GeoLocation data can be changed even if the Survey Point is locked.

 

Example

bool lockedState = true;
ACAPI_Environment (APIEnv_SetSurveyPointLockedID, &lockedState);

 

Requirements

Version: API 25 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_IsSurveyPointLockedID
API_GeoLocation
APIEnv_SetGeoLocationID
APIEnv_GetSurveyPointTransformationID
ACAPI_Environment
API Functions