APIESYMCommandProc

User supplied callback function for handling external symbols.

    typedef GSErrCode  APIESYMCommandProc (
        const API_ESYMParams*     esymParams
    );

 

Parameters

esymParams
[in] This structure contains the various parameters identifying the external symbol (type, index) and the type of operation (new/edit).

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document. This is the replacement function for the DoCommand function, when it was called with the DO_TOOLBOX_ method.

 

Remarks

This is the function which will be called when your add-on installed it with ACAPI_Install_ESYMHandler.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

API_ESYMParams
ACAPI_Install_ESYMHandler
API Functions