APIExternalCallBackProc

Callback function for handling the responses of asynchronous external module command calls.

    typedef GSErrCode  APIExternalCallBackProc (
        GSHandle      params,
        GSErrCode     returnCode
    );

 

Parameters

params
[in/out] the passed parameters for the module command
returnCode
[in] the return value of the APIModulCommandProc function of the server side add-on

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This is the handler function to be used for collecting the results of external module command calls in asynchronous case.

For more details refer to the description of the ACAPI_Command_ExternalCall function.

 

Example

Check the ExternalCallBackProc function in the Communication Manager example add-on.

 

Requirements

Version: API 10 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Command_ExternalCall
Communication Manager
API Functions