User supplied callback procedure for handling I/O operations.
typedef GSErrCode APIIO3DCommandProc ( const API_IOParams* ioParams, Modeler::SightPtr sight );
Parameters
- ioParams
- [in] This structure contains the various parameters identifying the file to be opened or saved.
- sight
- [in] The 3D sight pointer.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This is the function which will be called when your add-on installed it with ACAPI_Install_FileTypeHandler3D.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Callback.h