APIIo_​GetPointID

Performs a point input.

    GSErrCode ACAPI_Interface (
        APIIo_GetPointID,
        API_GetPointType*       pointInfo,
        RubberLineInfoProc*     rubberLineInfoProc,
        Get3DComponentProc*     get3DComponentProc
    );

 

Parameters

pointInfo
[in/out] Parameters of the point input operation.
rubberLineInfoProc
[in] Callback function for custom feedback drawing.
get3DComponentProc Modified in 14
[in] Callback function for getting elem informations online (realtime).

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
pointInfo is nullptr
APIERR_BADPLANE
invalid plane definition in pointInfo
APIERR_BADWINDOW
the operation cannot be performed in the current front window of the application
APIERR_CANCEL
the input was canceled by the user

For other common API errors see the API Errors document.

 

Remarks

This function is used to let the user input a point graphically.

If the input process has failed, the function returns APIERR_CANCEL. Otherwise the result is returned in the pos and neig fields of pointInfo.

The prompt string displayed in the control box which can contain instructions about the action. You can control the cursor gravity above neigs and the cursor shapes, and set the input plane. There is a possibility of drawing own graphical feedback during the input with passing a pointer to your rubber line callback function. For more details on the utilization refer to the documentation of the API_GetPointType structure.

Do not invoke any input operation while there are modal dialogs open.

 

Example

See the examples of the APIIo_GetArcID and APIIo_DrawRubberLineID functions.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Interface.h

 

See Also

API_GetPointType,
RubberLineInfoProc, APIIo_DrawRubberLineID, APIIo_GetLineID, APIIo_GetArcID, APIIo_GetPolyID,
ACAPI_Interface, API Functions