APIIo_​IsProcessCanceledID

Checks for user breaks during long processes.

    GSErrCode ACAPI_Interface (
        APIIo_IsProcessCanceledID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_CANCEL
The current process was canceled

For other common API errors see the API Errors document.

 

Remarks

This function is used to check whether the user has canceled a long process (by clicking on the Cancel button of the process window, or by pressing the appropriate keys on the keyboard).

It also give visual feedback on processing by changing the cursor shape.

 

Example

See APIIo_InitProcessWindowID for example of using process windows.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_InitProcessWindowID,
ACAPI_Interface, API Functions