Invokes the “Open Library Part” dialog.
GSErrCode ACAPI_Interface ( APIIo_OpenLibPartFileDialogID, bool* retCode, IO::Location* location, bool* isGSM bool* wasExternalEditorInvoked );
Parameters
- retCode
- Return code is true when a valid gsm file is successfully opened in the “Open Library Part” dialog.
- location
- Location of the selected library part.
- isGSM
- [in] Optional parameter. If it is set to true, the file filter in the open dialog is set to “General GDL Objects”.
- wasExternalEditorInvoked
- [out] Optional parameter. If it is set to true, the file was opened using an external editor.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This function invokes the “Open Library Part” dialog, and returns the chosen library part’s location.
Requirements
- Version: API 13 or later
- Header: APIdefs_Interface.h