APIIo_​OpenOtherObjectDialogID

Invokes the “Open Library” dialog.

    GSErrCode ACAPI_Interface (
        APIIo_OpenOtherObjectDialogID,
        bool*             retCode,
        IO::Location*     location,
        bool*             isRoom
    );

 

Parameters

retCode
[out] Return code. True if the zone stamp or label object file selected in the file open dialog was opened successfully.
location
The location of the library part.
isRoom
[in] Optional parameter. Defines the type of the file in the file open dialog (true – the file type is Zone, nullptr or false – the file type is Label)

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function is used to let the user open a file of type Zone Stamp or Label, using the Open File Dialog. The location is set only if a valid Zone Stamp or Label file was selected in the “Open File” dialog.

 

Requirements

Version: API 13 or later
Header: APIdefs_Interface.h

 

See Also

ACAPI_Interface,
APIIo_OpenLibPartFileDialogID,
APIIo_OpenPictureDialogID,

API Functions