APIIo_​OpenPictureDialogID

Opens an “Open Picture” dialog (same dialog as on Material Settings, Texture tabpage).

    GSErrCode ACAPI_Interface (
        APIIo_OpenPictureDialogID,
        bool*             retCode,
        IO::Location*     location
    );

 

Parameters

retCode
[out] True if a valid picture format file is selected in the “Open Picture” dialog.
location
[out] The location of the selected Picture format file.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Invokes the Open Picture (Load Image from Library) dialog, and returns the chosen picture’s location. Also adds the chosen picture to the Embedded Library if it was not part of that previously.

 

Requirements

Version: API 13 or later
Header: APIdefs_Interface.h

 

See Also

ACAPI_Interface,
APIIo_OpenLibPartFileDialogID,
APIIo_OpenOtherObjectDialogID,
API Functions