Sets the value of the progress bar.
GSErrCode ACAPI_Interface ( APIIo_SetProcessValueID, Int32* newval );
Parameters
- newval
- [in] The new value of the progress bar in the current process phase.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
newval
is nullptr
For other common API errors see the API Errors document.
Remarks
This function is used to set the progress bar value of the current phase in the process window.
Use the APIIo_IncProcessValueID function to increment the process value, instead of setting it to a given value.
Example
See APIIo_InitProcessWindowID for example of using process windows.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Interface.h
See Also
APIIo_InitProcessWindowID, APIIo_IncProcessValueID,
ACAPI_Interface, API Functions