Opens a tool settings dialog.
GSErrCode ACAPI_Interface ( APIIo_SettingsDialogID, API_ToolBoxItem* toolBoxItem, API_Guid* guid );
Parameters
- toolBoxItem
- [in] The parameters to open the dialog with.
- guid
- [in] Special unique identifier of the dialog, used in automated testing.
Return Values
NoError
- The function has completed with success.
APIERR_BADID
toolBoxItem->type
is invalid.APIERR_CANCEL
- CANCEL was hit.
For other common API errors see the API Errors document.
Remarks
The Settings dialog is identified with toolBoxItem->type
.
Example
GSErrCode SettingsDialog (void) { const API_Guid mySettingsDlgGuid = APIGuidFromString ("2A92ACAC-1E8C-40EC-9FAF-3171A07E1729"); API_ToolBoxItem tbi = {}; tbi.type = API_WallID; return ACAPI_Interface (APIIo_SettingsDialogID, &tbi, &mySettingsDlgGuid); }
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Interface.h