Defines the menu where the add-on’s menu command will appear.
typedef enum { MenuCode_UserDef, MenuCode_File, MenuCode_Edit1, MenuCode_Edit2, MenuCode_Edit3, MenuCode_Tools, MenuCode_Options1, MenuCode_Options2, MenuCode_Image, MenuCode_Calculate, MenuCode_TeamWork, MenuCode_Display, MenuCode_Palettes, MenuCode_Extras, MenuCode_Hotlink, MenuCode_GDLObjects, MenuCode_3DView, MenuCode_DocExtras, MenuCode_Interoperability MenuCode_ModelCheck } APIMenuCodeID;
Members
- MenuCode_UserDef
- configurable by the user
- MenuCode_File
- into the File menu after Info
- MenuCode_Edit1
- into the Edit menu after Find & Select
- MenuCode_Edit2
- into the Edit/Reshape submenu
- MenuCode_Edit3
- into the Edit/Move submenu
- MenuCode_Tools
- into the Options menu, after the separator below the layers
- MenuCode_Options1
- into the Options menu, after Show All Layers
- MenuCode_Options2
- into the bottom of Options/Attributes submenu
- MenuCode_Image
- to the end of Document/Creative Imaging submenu
- MenuCode_Calculate
- to the end of Document/Schedules and Lists submenu
- MenuCode_TeamWork
- to the end of TeamWork menu
- MenuCode_Display
- to the end of View/Zoom submenu
- MenuCode_Palettes
- to the end of Window/Palettes submenu
- MenuCode_Extras
- to the end of Design/Design Extras submenu
- MenuCode_Hotlink
- into the File/External Content submenu
- MenuCode_GDLObjects
- into the File/Libraries and Objects submenu
- MenuCode_3DView
- into the Document/Set 3D View submenu
- MenuCode_DocExtras
- into the Document/Document Extras menu
- MenuCode_Interoperability
- into the File/Interoperability submenu
- MenuCode_ModelCheck
- into the Design/Model Check submenu
Remarks
This structure is used in the ACAPI_Register_Menu function.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Registration.h