APIModulCommandProc

User supplied callback procedure for handling calls from other add-ons.

    typedef GSErrCode  APIModulCommandProc (
        GSHandle     params,
        GSPtr        resultData,
        bool         silentMode
    );

 

Parameters

params
[in/out] This structure contains the parameters of the command passed onto your add-on.
resultData
[out] This structure contains parameters passed back to the caller add-on.
silentMode
[in] This flag tells the add-on to work “silently”, i.e. skip all dialogs and warning messages.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Your add-on can provide services to other add-ons by calling ACAPI_Register_SupportedService in its RegisterInterface function. After that any add-on can call your add-on which knows the command’s interface; and this function will be the entry point of your add-on in this case.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

Communication Manager, API Functions