APINavigator_​CloneProjectMapItemToViewMapID

Clones a Navigator item from the project map to view map.

    GSErrCode ACAPI_Navigator (
        APINavigator_CloneProjectMapItemToViewMapID,
        API_Guid*       sourceItemId,
        API_Guid*       parentItemId,
        API_Guid*       createdItemId
    );

 

Parameters

sourceItemId
[in] Navigator item to be cloned.
parentItemId
[in] Parent navigator item of the cloned navigator item.
createdItemId
[out] Cloned navigator item.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
sourceItemId or parentItemId is nullptr or invalid.
APIERR_GENERAL
General internal error.

For other common API errors see the API Errors document.

 

Remarks

This function is used to clone a navigator item from the project map to view map by specifying the navigator item to be cloned and the parent in the view map.

The properties of the cloned view can be changed with the APINavigator_ChangeNavigatorViewID navigator function.

 

Requirements

Version: API 24 or later
Header: APIdefs_Navigator.h

 

See Also

APINavigator_ChangeNavigatorViewID
ACAPI_Navigator
API Functions