Deletes the given navigator view.
GSErrCode ACAPI_Navigator ( APINavigator_DeleteNavigatorViewID, const API_Guid* viewGuid, const bool* silentMode );
Parameters
- viewGuid
- The unique identifier of the view.
- silentMode
- This parameter is used for turn on/off the warning messages comes from Archicad during deleting a view.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- You will encounter with this return value, if something was wrong with the parameters.
For other common API errors see the API Errors document.
Example
This is an example for view deletion, based on the Navigator_Test test addon.
Int32 selected = DGTreeViewGetSelected (dialogID, NavTreeView, DG_TVI_ROOT); if (DBERROR (selected == DG_TVI_NONE)) return; bool silentMode = true; API_Guid guid = NavigatorTestGlobals::Instance ().GetNavigatorItem ((UIndex) DGTreeViewGetItemUserData (dialogID, NavTreeView, selected)); ACAPI_Navigator (APINavigator_DeleteNavigatorViewID, &guid, &silentMode);
Remarks
This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.
Requirements
- Version: API 17 or later
- Header: APIdefs_Navigator.h