APINavigator_​DeleteNavigatorVPItemID

Deletes a Navigator viewpoint root, group or leaf node from the Project Map.

    GSErrCode ACAPI_Navigator (
        APINavigator_DeleteNavigatorVPItemID,
        const API_Guid*     guid
    );

 

Parameters

guid
[in] GUID of the viewpoint root, group or leaf node to delete.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
guid was nullptr.
APIERR_BADID
guid designetes an object which does not exist, or it is not a Navigator viewpoint root, group or leaf node of the current AddOn.
APIERR_NOACCESSRIGHT
The function was called in teamwork mode, and a root or group was to be deleted.
APIERR_NOTMINE
In teamwork mode, the current user has not reserved the viewpoint root, group or leaf node designated by guid.

For other common API errors see the API Errors document.

 

Remarks

If a root or group is deleted, all descendants are also deleted.

Note: In teamwork mode you cannot create, change or delete viewpoint roots or groups.

 

Requirements

Version: API 22 or later
Header: APIdefs_Navigator.h

 

See Also

ACAPI_Navigator,
API Functions