APINavigator_​GetNavigatorItemID

Retrieves a navigator item.

    GSErrCode ACAPI_Navigator (
        APINavigator_GetNavigatorItemID,
        const API_Guid*        guid,
        API_NavigatorItem*     navigatorItem
    );

 

Parameters

guid Changed in API 11
[in] The GUID of the navigator item
navigatorItem
[in/out] Data of the navigator item (you should set mapId for performance).

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The guid or the navigatorItem parameter is nullptr, or contains invalid data.
APIERR_GENERAL
No open project.

 

Remarks

This function is used to get an item of the Project Navigator.

 

Example

Refer to the Navigator_Test example project of the API Development Kit.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorItem
APINavigator_GetNavigatorParentItemID
APINavigator_GetNavigatorChildrenItemsID
ACAPI_Navigator
API Functions