Retrieves information of a Project Navigator Map or Publisher Set.
GSErrCode ACAPI_Navigator ( APINavigator_GetNavigatorSetID, API_NavigatorSet* navigatorSet, Int32* index );
Parameters
- navigatorSet
- [in/out] Data of the Project Navigator’s Map. Identified with
mapId
. - index
- [in] Index of the required set. Used only for Publisher Sets.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
navigatorSet
or theindex
parameter isnullptr
. APIERR_BADINDEX
- The
index
parameter contains invalid data. APIERR_GENERAL
- No open project.
Remarks
This function is used to retrieve the name and GUID parameters of a given Project Navigator Map.
Example
API_NavigatorSet set; //navigator maps for (Int32 mapId = API_ProjectMap; mapId < API_PublisherSets; mapId++) { BNZeroMemory (&set, sizeof (API_NavigatorSet)); set.mapId = (API_NavigatorMapID) mapId; err = ACAPI_Navigator (APINavigator_GetNavigatorSetID, &set, nullptr); if (err == NoError) ACAPI_WriteReport (set.name, false); } //publisher sets Int32 nSet = 0; GSErrCode err = ACAPI_Navigator (APINavigator_GetNavigatorSetNumID, &nSet, nullptr); if (err == NoError) { for (Int32 i = 0; i < nSet && err == NoError; i++) { BNZeroMemory (&set, sizeof (API_NavigatorSet)); set.mapId = API_PublisherSets; err = ACAPI_Navigator (APINavigator_GetNavigatorSetID, &set, &i); if (err == NoError) ACAPI_WriteReport (set.name, false); } }
Requirements
- Version: API 4.3 or later
- Header: APIdefs_Navigator.h
See Also
API_NavigatorSet
APINavigator_GetNavigatorSetNumID
ACAPI_Navigator
API Functions