Retrives a navigator view.
GSErrCode ACAPI_Navigator ( APINavigator_GetNavigatorViewID, API_NavigatorItem* navigatorItem, API_NavigatorView* navigatorView );
Parameters
- navigatorItem
- [in] The requested navigator item identified with GUID (you should set
mapId
for performance). - navigatorView
- [out] Data of the navigator item
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
navigatorItem
or thenavigatorView
parameter isnullptr
, or contains invalid data. APIERR_GENERAL
- No open project.
Remarks
This function is used to get the view settings of an item of the Project Navigator.
Example
See the example of APINavigator_SearchNavigatorItemID.
Requirements
- Version: API 4.3 or later
- Header: APIdefs_Navigator.h