APINavigator_​GetNavigatorVPItemID

Gets information about an existing Navigator viewpoint root, group or leaf node in the Project Map.

    GSErrCode ACAPI_Navigator (
        APINavigator_GetNavigatorVPItemID,
        API_NavigatorAddOnViewPointData*     viewPointData
    );

 

Parameters

viewPointData
[in/out] The guid member should be provided before call. The result of the query will be filled in the other members on return.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
viewPointData was nullptr.
APIERR_BADID
viewPointData.guid designetes an object which does not exist, or it is not a Navigator viewpoint root, group or leaf node of the current AddOn.

For other common API errors see the API Errors document.

 

Remarks

viewPointData.viewSettingsFlags is set to API_NavgatorViewSettingsNoAttributeID, if viewPointData.guid designates a root or a group.

 

Requirements

Version: API 22 or later
Header: APIdefs_Navigator.h

 

See Also

ACAPI_Navigator,
API Functions