Registers an object with virtual functions that is implemented by the AddOn, and on certain events called by Archicad.
GSErrCode ACAPI_Navigator ( APINavigator_RegisterCallbackInterfaceID, INavigatorCallbackInterface* callBackInterface );
Parameters
- callBackInterface
- [in] Pointer to the callback interface object to register.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
callBackInterface
wasnullptr
.
For other common API errors see the API Errors document.
Remarks
The object pointed to by callBackInterface
must be derived from INavigatorCallbackInterface
.
Its lifetime must be managed by the AddOn.
Requirements
- Version: API 22 or later
- Header: APIdefs_Navigator.h