APINavigator_​SetNavigatorItemPositionID

With this function a navigator item can be moved to an other place. It can be used with items on the layout map and on the view maps (in case of teamworking on the public and on the users’ own view map as well.

    GSErrCode ACAPI_Navigator (
        APINavigator_SetNavigatorItemPositionID,
        const GS::Guid*     source,
        const GS::Guid*     parent,
        const GS::Guid*     child
    );

 

Parameters

source
The guid of the item, what you want to replace.
parent
The new parent of the replaced item.
child
If it is nullptr, then the item will be inserted to the first place on the actual level, otherwise the it will be inserted after the child.

 

Return Values

NoError
Everything is OK.
 
APIERR_BADPARS
This value can be returned in several cases: the source or the parent parameter is nullptr, or the source or the parent guid was not found in the layout map and neither in the view maps, or the source item cannot be moved to the desired destination.
 
APIERR_NOACCESSRIGHT
In case of teamworking, if the user not owns (locked) the item which (s)he wants to move then the user has no access right…
 

 

Remarks

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 15 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorItem
APINavigator_GetNavigatorItemID
APINavigator_GetNavigatorParentItemID
APINavigator_GetNavigatorChildrenItemsID
ACAPI_Navigator
API Functions