User supplied callback function for processing the drawing numbering grid lines.
typedef GSErrCode APINumberingGridLineProc ( const API_NumberingGridLine* gridLine );
Parameters
- gridLine
- [in] This structure contains parameters (coordinates, pen color, line type) of the current drawing numbering grid lines
Return Values
The callback function is expected to return NoError
.
Remarks
This callback function is used with the APIEnv_GetNumberingGridLinesID environment function to get the lines of the drawing numbering grid of the current Archicad layout database.
Example
// ============================================================================ // Retrieving Drawing Numbering Grid Lines // ============================================================================ static GSErrCode __ACENV_CALL CustomNumberingGridLineProc (API_NumberingGridLine *gridLine) { char msgStr[256]; sprintf (msgStr, "Grid line coordinates: (%e, %e), (%e, %e)", gridLine->begC.x, gridLine->begC.y, gridLine->endC.x, gridLine->endC.y); ACAPI_WriteReport (msgStr, false); return NoError; } // CustomNumberingGridLineProc
Requirements
- Version: API 6.1 or later
- Header: APIdefs_Callback.h
See Also
API_NumberingGridLine
APIEnv_GetNumberingGridLinesID
API Functions