Callback procedure for creating custom tabpages.
typedef GSErrCode APIPanelCreateProc ( Int32 refCon, const void* tabControl, void* data, void** tabPage );
Parameters
- refCon
- [in] reference number passed by the panel registration function
- tabControl
- [in] pointer to the constructed
DG::TabControl
dialog item - data
- [in] pointer to an interface which provides access to the user data
- tabPage
- [out] pointer to the tabpage object instance created in the callback function
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
When the additional panel is being created, a callback function is called which lets the add-on initialize the tabpage item with the associated user data and an attached observer to it.
Install this handler function with ACAPI_Install_PanelHandler in order to be called to create your tabpage identified with
refCon
and attach the observer to it when the settings dialog is being constructed.
Example
Refer to the Panel_Test example project of the API Development Kit.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Callback.h
See Also
ACAPI_Install_PanelHandler
APIPanelDestroyProc
ACAPI_Register_SettingsPanel
ACAPI_Register_InfoBoxPanel
ACAPI_Register_AttributePanel
Custom Panels in Settings Dialogs
API Functions