APIPanelDestroyProc

Callback procedure for destroying custom tabpages.

    typedef GSErrCode  APIPanelDestroyProc (
        Int32     refCon,
        void*     tabPage
    );

 

Parameters

refCon
[in] reference number passed by the panel registration function
tabPage
[in] pointer to the tabpage object instance

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

When the additional panel is being destroyed, a callback function is called in order to detach the tabpage observer, destruct the tabpage item, and free the associated user data.

6.1  Install this handler function with ACAPI_Install_PanelHandler in order to be called to detach the observer and destroy your tabpage identified with refCon when the settings dialog closes.

 

Example

Refer to the Panel_Test example project of the API Development Kit.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Install_PanelHandler
APIPanelCreateProc
ACAPI_Register_SettingsPanel
ACAPI_Register_InfoBoxPanel
ACAPI_Register_AttributePanel
Custom Panels in Settings Dialogs
API Functions