APIPropertyObjectCommandProc

Callback function to handle the different property assignments.

    typedef GSErrCode  APIPropertyObjectCommandProc (
        API_PropertyObjectParams*     propertyParams
    );

 

Parameters

propertyParams
[in] the parameters of the property assignment.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Example



GSErrCode   __ACENV_CALL   APIPropertyObjectHandlerProc (API_PropertyObjectParams *propertyParams)
{
    switch (propertyParams->cmd) {
        case APIPropObj_AssignProperty:
            GetPropertyObjectName (propertyParams->propertyName);
            break;

        case APIPropObj_DisableProperty:
            checked = false;
            UncheckMenu ();
            break;

        default:
            break;
    }

    return NoError;
}

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

API_PropertyObjectParams,
ACAPI_Register_PropertyObjectHandler, ACAPI_Install_PropertyObjectHandler
API Functions