APISettingsCreateProc

Callback procedure for handle settings dialog create event.

    typedef GSErrCode  APISettingsCreateProc (
        void*  uiData,
    );

 

Parameters

uiData
[in/out] pointer to the tool UI data. This UI data can be used to get the current settings and to attach an observer which monitors changes of the settings dialog.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

When the settings dialog is being created, the callback function is called which lets the add-on get the current settings and attach an observer to the tool UI data.

Install this handler function with ACAPI_Install_SettingsHandler.

 

Example

Refer to the Panel_Test example project of the API Development Kit.

 

Requirements

Version: API 20 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Install_SettingsHandler
APISettingsDestroyProc
ACAPI_Register_SettingsObserver
API Functions