APISettingsDestroyProc

Callback procedure for handle settings dialog destroy event.

    typedef GSErrCode  APISettingsDestroyProc (
        void*  uiData,
    );

 

Parameters

uiData
[in/out] pointer to the tool UI data.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

When the settings dialog is being destroyed, a callback function is called in order to detach tool UI data observer.

Install this handler function with ACAPI_Install_SettingsHandler.

 

Example

Refer to the Panel_Test example project of the API Development Kit.

 

Requirements

Version: API 20 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Install_SettingsHandler
APISettingsCreateProc
ACAPI_Register_SettingsObserver
API Functions