To have an overview on the 3D model of Archicad, and how the 3D database fits into the entire database system please refer to the Element Overview chapter.
Only the handler functions are explained in full detail here.
Handler functions
All of the Body handler functions begin with the ACAPI_Body_ prefix. This function family gives support create or modify the body of a morph element. When editing an existing body, you can only append your modifications, you cannot modify the original body. Refer to the functions below to have details on these topics.
ACAPI_Body_Create
ACAPI_Body_Finish
ACAPI_Body_Dispose
ACAPI_Body_AddVertex
ACAPI_Body_AddEdge
ACAPI_Body_AddPolyNormal
ACAPI_Body_AddPolygon
General Error Codes
APIERR_BADPARS |
invalid parameter; |