Overview
This feature of the Archicad allows one to control whether specific Classifications should be visible in the element settings dialog or not.
- To tell Archicad that your add-on wants to modify classification visibility use ACAPI_Register_ClassificationVisibilityHandler.
- To install the callback function which decides if a classification should be visible or not use ACAPI_Install_ClassificationVisibilityHandler.
Handler functions
ACAPI_Element_IsClassificationItemVisible
ACAPI_Element_IsClassificationItemVisibleDefault
ACAPI_Attribute_IsClassificationItemVisible
Use ACAPI_Notify_ClassificationVisibilityChanged to send a notification
Use ACAPI_Notify_CatchProjectEvent withAPINotify_ClassificationVisibilityChanged
parameter to receive notifications
Overview
This feature of the Archicad allows one to control whether specific Properties should be visible in the element settings dialog or not.
- To tell Archicad that your add-on wants to modify property visibility use ACAPI_Register_PropertyVisibilityHandler.
- To install the callback function which decides if a property should be visible or not use ACAPI_Install_PropertyVisibilityHandler.
Handler functions
The following functions let you query whether a specific property definition is visible or not.
ACAPI_Element_IsPropertyDefinitionVisible
ACAPI_Element_IsPropertyDefinitionVisibleDefault
ACAPI_Attribute_IsPropertyDefinitionVisible
The following functions let you send and receive APINotify_PropertyVisibilityChanged
notifications.
Use ACAPI_Notify_PropertyVisibilityChanged to send a notification
Use ACAPI_Notify_CatchProjectEvent withAPINotify_PropertyVisibilityChanged
parameter to receive notifications