Element Database


To have an overview what the elements are, and how they fit into the entire database please refer to the Element Overview chapter.

On these pages only the used structures are explained in full detail.

 

Structures

There is a container data structure, which is a union that can hold the data of any element type. Also there is another structure which has many data arrays to provide non-fixed size parameters of an element; called additional (memo) information.

API_Element
API_ElementMemo

The structures below correspond to a specific element; each of them represent one element type.

API_WallType
API_ColumnType
API_ColumnSegmentType
API_BeamType
API_BeamSegmentType
API_WindowType
API_DoorType
API_SkylightType
API_ObjectType
API_LampType
API_SlabType
API_RoofType
API_ShellType
API_MorphType
API_MeshType

API_DimensionType
API_RadialDimensionType
API_LevelDimensionType
API_AngleDimensionType

API_TextType
API_LabelType
API_ZoneType

API_HatchType
API_LineType
API_PolyLineType
API_ArcType
API_CircleType
API_SplineType
API_HotspotType
API_ChangeMarkerType
API_DetailType
API_WorksheetType
API_DrawingType
API_PictureType

API_CutPlaneType
API_CameraType
API_CamSetType

API_CurtainWallType
API_CWSegmentType
API_CWFrameType
API_CWPanelType
API_CWJunctionType
API_CWAccessoryType

API_StairType
API_StairRiserType
API_StairTreadType
API_StairStructureType

API_SectElemType

API_RailingType
API_RailingSegmentType
API_RailingPatternType
API_RailingPanelType
API_RailingInnerPostType
API_RailingRailType
API_RailingHandrailType
API_RailingToprailType
API_RailingNodeType
API_RailingRailConnectionType
API_RailingRailEndType
API_RailingBalusterSetType
API_RailingBalusterType
API_RailingPostType