The API_...Relation
structures describe the connections of a certain wall, beam or room element to other elements.
These structures are used for returning the relation information only, and cannot be used for modifying the database.
To learn more about the usage of element relation structures please refer to the ACAPI_Element_GetRelations function.
Structures
API_BeamRelation
API_BeamSegmentRelation
API_WallRelation
API_RoomRelation
API_RoofRelation
API_ShellRelation
API_CWPanelRelation
API_SkylightRelation
API_WindowRelation
API_DoorRelationAPI_WallPart
API_CWSegmentPart
API_Niche
API_BeamPart