The IAPIAttributeAdapter template interface provides a simple abstract method (CacheAttributes ()) to cache an API structure’s attributes by storing them in an IAttributeProxy object.
The IAPIAttributeAdapterBase interface provides Get/Set methods and data members for information necessary during the caching:
- the IAttributeProxy object which stores the cached attributes
- an IAPIAttributeAdapterFactory to get attribute adapters for contained types
- the API_DatabaseInfo of the structure
The derived IAPIAttributeAdapter template interface provides additional type-dependent Get/Set methods and data members for information necessary during the caching:
- the structure to cache
- the API_ElementMemo for an API_Element structure
There’s a simple implementation in the DefaultImplementation folder, which basically does nothing (NullTypeAttributeAdapter).
Requirements
Namespace: GSAPI
Header: IAPIAttributeAdapter.hpp
Version: API 10.21 or later
See Also
IAttributeProxy interface | IAPIAttributeAdapterFactory interface