This interface provides the necessary abstract methods to create an attribute adapter for any kind of structure found in an API_Element, API_ElementMemo or API_PrimElement. Since these API types do not have a common ancestor type it is necessary to create a different overload for each type. If the user doesn’t need to create every type of adapter it is advised to derive the AttributeAdapterFactory from the NullTypeAttributeAdapterFactory in the DefaultImplementation folder, and overload only the necessary virtual methods. The interface also holds a reference to the IAttributeProxy instance which caches the used attributes, which it sets for each adapter it returns. There’s also a managedAdapters flag which tells whether the factory is responsible for destroying the adapters (true) or not (false). This flag was added to support flyweight factories.
Requirements
Namespace: GSAPI
Header: IAPIAttributeAdapterFactory.hpp
Version: API 10.21 or later