The IAPIOutputAdapter template interface provides a simple abstract method to output an API structure or enum on a GS::OChannel. (There’s a compulsory operator>> () overload which is usually a wrapper for the compulsory Output () method.)
The IAPIOutputAdapterBase interface provides Get/Set methods and data members for information necessary during the output:
- an IAPIOutputManager, to get the output channel from for contained types
- an IAPIOutputAdapterFactory to get output adapters for contained types
- the API_DatabaseInfo of the structure/enum
- an optional IAttributeProxy, to cache attributes of the structure
- the attribute output type (GSAPI::DoNotOutput by default)
The derived IAPIOutputAdapter template interface provides additional type-dependent Get/Set methods and data members for information necessary during the output:
- the structure/enum to output
- the API_ElementMemo for an API_Element structure
There’s a simple implementation in the DefaultImplementation folder, which basically does nothing (NullTypeOutputAdapter).
Requirements
Namespace: GSAPI
Header: IAPIOutputAdapter.hpp
Version: API 10.21 or later
See Also
IAPIOutputManager interface | IAPIOutputAdapterFactory interface | IAttributeProxy interface