GSAPI::IAPIOutputManager interface

This interface provides the necessary abstract methods to get an output channel (GS::OChannel, typically an IO::File) for any kind of structure or enum found in an API_Element, API_ElementMemo, API_PrimElement, API_Attribute, API_AttributeDefExt or API_LayoutInfo. Since these API types do not have a common ancestor type it is necessary to create a different overload for each type. There’s a simple implementation in the DefaultImplementation folder, which takes an IO::Location as constructor parameter, creates a file there and redirects all output to that file (FileOutputManager).

Requirements

Namespace: GSAPI

Header: IAPIOutputManager.hpp

Version: API 10.21 or later