Callback function to import attributes from the new registered import format.
typedef GSErrCode ImportAttrProc ( const IO::Location& fileName, const GS::Array<GS::Pair<API_Attribute, API_AttributeDefExt*>>& result );
Parameters
- fileName
- [in] The path from where to read the attributes.
- result
- [out] The read attributes. These will appear in the Attribute Manager.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Requirements
- Version: API 26 or later
- Header: APIdefs_Callback.h