Known and Fixed Bugs in Former Releases

These tables enumerate the API related defects already fixed in former Archicad versions, indicating the number of the program build in which the correction was made.


API related bugs fixed in Archicad 21

Ref. # Build Defect summary
API 21

 


API related bugs fixed in Archicad 20

Ref. # Build Defect summary
API 20

 


API related bugs fixed in Archicad 19

Ref. # Build Defect summary
API 19

 


API related bugs fixed in Archicad 18

Ref. # Build Defect summary
API 18
27854 154 APIAny_NeigToCoordID function does not check invalid inIndex
34795 138 ACAPI_Element_SetUserData breaks the link between elements and associated dimensions if the APIUserDataFlag_UndoAble flag is set
39641 138 Element links on Section window are not updated when Section is rebuilt from model
116800 58 Request for Structure display support in API filter flag (ACAPI_Element_Filter)
149995 177 Morph sub-selection information cannot be accessed (API_Neig)
169179 2305 Unable to get the renovation filter guid (APIDb_GetRenovationFiltersID)
173546 2504 Request to get ‘Merged Element’ information (ACAPI_Element_Merge_GetMergedElements)
173569 2504 PetPalette icons are missing (API_PetPaletteType)
173913 2508 Function to get elements inside given polygon (ACAPI_Selection_Get)
174089 2504 Deleting elements takes a long time (ACAPI_Element_Delete)
174861 2508 Request to get all hotspots of any element (ACAPI_Element_GetHotspots)

 


API related bugs fixed in Archicad 17

Ref. # Build Defect summary
API 17
31674 28 The APIDb_HideElementID database function does nothing (function code removed)
34815 5572 Modifying additional parameters of an object from an add-on’s custom panel appended to the Object Settings dialog has not effect on the object’s preview
54272 2230 API_ProjectInfo does not tell if signed in TeamWork Administrator mode (not relevant any more)
67485 2228 Element ID conversion routines do not work from APINotify_ConvertUnId and APINotify_ConvertGuid project event handlers during file merge operation (not relevant any more)
129155 2400 Cannot delete a view via API (APINavigator_DeleteNavigatorViewID)
149054 1215 Check if element is hidden by renovation (ACAPI_Element_Filter)
156094 3000 Cannot access the view orientation rotate angle (APIDb_GetZoomID)
154360 2230 APIIo_SetMenuItemTextID to support unicode strings
157122 3303 API access to Morph’s soft points (ACAPI_3D_GetCutPolygonInfo)
157150 2705 Can no longer save binary GDL from 3D (APIDo_SaveID)
161354 3325 Unable to create single-plane roof
166881 5008 Cannot create story above the topmost floor
167759 5572 Changing LibPart and Parameters in Object settings dialog
168823 6502 APIDb_StoreViewSettingsID crashed
169628 5560 APIIo_GetPointID returns bad 3D face with composite elements

 


API related bugs fixed in Archicad 16

Ref. # Build Defect summary
API 16
126410 2206 Roof element is notified when dragging its skylight objects
127654 43 ACAPI_Element_GetDefaults does not retrieve the window/door default parapet height
128853 56 The API Zone parameter roomLSize cannot be modified
129333 62 Cannot get settings of a Subset Navigator item
133392 2203 Request for IFC property and attribute creation for elements in API
134039 2206 Window/door vs wall notifications
135883 1208 Get name of missing library part (ACAPI_LibPart_Get)
137325 2207 New GDL Request for Archicad running mode (APIEnv_ProtectionDataID)
138064 2207 APIDb_CalcBoundsID returns incorrect coordinates for SkyLight, CurtainWallSegment and CurtainWallPanel
143450 3478 APINavigator_NewNavigatorViewID can’t create elevation views
149400 3478 API_ElevationNavItem is missing from APINavigator_SearchNavigatorItemID
157126 3325 Can no longer reserve another element as part of a reservation event/edit action
162392 4202 Cannot save List Window content into PDF format (APIDo_SaveID)
162579 4009 ACAPI_Notify_GetParentElement crashes after dragging/mirroring a copy of a section/elevation marker, label or camera element

 


API related bugs fixed in Archicad 15

Ref. # Build Defect summary
API 15
115160 1200 Element Info Tag of a 3rd-party registered subtype tool element shows only the name of the tool
115490 341 API_ProjectInfo::untitled is not set by APIEnv_Project
124707 2501 APIDo_PublishID does not allow publishing individual items
126220 2612 ACAPI_Element_Change crashes with null mask
127119 3202 APIDo_SaveID does not support PDF format
128261 3448 ACAPI_Element_GetDefaults does not fill the nonBreaking member of API_TextType
132425 3460 Cannot save IFC file
135272 3822 Zone memo parameters are incorrect in settings dialog callback

 


API related bugs fixed in Archicad 14

Ref. # Build Defect summary
API 14
82760 1304 ACAPI_Element_Create does not check Wall index parameters when creating polygonal wall
83029 1201 Cannot get which 3D Component or Body has been clicked on in 3D
88394 1304 “Create new detail viewpoint” cannot be get/set for details
108788 2702 ACAPI_LibPart_GetSectionList returns APIERR_GENERAL
111211 3244 APIEnv_ProtectionDataID does not report the number of licenses
117794 3612 API notification APINotify_AllInputFinished is not sent after opening a plan
119764 3801 Cannot change rendering background image with APIEnv_ChangeRenderingSetsID
133877 4204 APIEnv_Change3DCuttingPlanesID does not work

 


API related bugs fixed in Archicad 13

Ref. # Build Defect summary
API 13
39554 1200 Panels registered with ACAPI_Register_AttributePanel do not appear in Material Settings dialog
81977 709 Cannot get zone stamp object for an API_ZoneType element
88524 1904 ACAPI_Element_Edit does not return the ids of copied elements
89874 1601 ACAPI_Attribute_Modify does not allow to rename Solid Line type attribute
90919 902 ACAPI_Element_Create crashes when hotlinking APIHotlink_Module type API_HotlinkType element
91638 2218 ACAPI_Element_GetRelations / API_RoomRelation always returns APIERR_MEMFULL if the room does not related to any Curtain Wall segments
94516 1602 Material attribute modifications with ACAPI_Attribute_Modify are not applied to 3D immediately
97120 2201 Ghost management (APIEnv_CreateGhostRecordID / APIEnv_DeleteGhostRecordID / APIEnv_ChangeGhostRecordID) is incomplete via API
97329 2202 ACAPI_3D_GetComponent function sets the uniStringNamePtr to nullptr
97381 2211 ACAPI_TeamworkControl_ReleaseElements does not work the way it should be, and there is no ACAPI_TeamworkControl_ReleaseElements function
99678 2511 APIDb_DrawElementID function does not work
131993 3836 Can’t set witness length from newly created dimension via API

 

API related bugs fixed in Archicad 12

Ref. # Build Defect summary
API 12
63842 304 Cannot create subset in Layout Map via API
64025 302 It is impossible to create a new autotext via API
65470 701 APIDb_CalcBoundsID does not return the correct zMin and zMax values of Object type elements
66780 608 Cannot access Story Level Lines checkboxes
68196 606 Drawing offset is not available in API_DrawingType
74573 1101 Notification is not sent about edge adjustment of polygonal elements
75123 1101 Notification is not sent about Elevate command performed in the 3D window
76584 1501 ACAPI_Notify_GetParentElement returns error in case of Drag a copy
77064 1604 Notifications are not sent when the door or window is edited
78047 1600 ACAPI_Element_GetElemList filtered with variationID does not work
80811 2011 APIAny_GetElemCreatorToolUnIdID returns APIERR_BADDATABASE error code if called from Detail or Worksheet windows
81382 2104 ACAPI_Element_SolidLink_Remove does not work
81716 2156 Partial Structure Display state cannot be modified with APIEnv_ChangeStructureDisplayID
83037 2332 APIAny_GetTextureCoordID crashes due to incorrect indexing
86092 2413 Cannot get 3D components of Curtain Wall elements with ACAPI_3D_GetComponent (also degenerated frames cannot be filtered; see APIDb_IsCWPanelDegenerateID)
93627 2673 API_LabelType does not return its parent’s GUID

 

API related bugs fixed in Archicad 11

Ref. # Build Defect summary
API 11
37281 775 Section line options (continuous or segmented) are missing from the API_CutPlaneType structure
42290 96 Support for longer file names
52833 331 Story Level lines switch of Section/Elevation settings is not available
53835 104 Window/Door detail expression strings are truncated to 128 characters in API_LibPartDetails structure
53949 951 Unable to change drawing’s polygon via API
58054 224 ACAPI_ListData_GetLocal retrieves the default listing data even if it is altered by the parameters of the element instance
64229 951 Cannot change mesh geometry with ACAPI_Element_Change and ACAPI_Element_ChangeMemo
64676 963 ACAPI_Element_GetQuantities does not update the zone
66517 1060 Cannot get deleted element by Guid
67033 1951 Crash caused by unnecessary call into the API when inserting layouts
67312 1081 Column userdata is lost when hotlinking plan file
86179 1251 ACAPI_Element_Change messes the dimension chain if attached to more elements

 

API related bugs fixed in Archicad 10

Ref. # Build Defect summary
API 10
28201 37 Ghost story info cannot be manipulated (see APIEnv_GetGhostStorySettingsID)
28747 246 The API interface of Project Navigator cannot identify the 3D model and listing databases (see API_NavigatorItem)
31673 201 Cannot save PlotMaker layout with API add-on (-> layouts are integrated into Archicad)
37598 797 APIDo_Zoom and APIDb_SetZoomID do not work on 3D window
37860 95 Cannot create label element on Detail Window
37938 37 Figure Transparency information is missing from API_PictureType
38813 201 API does not send element notifications above Detail Window
40191 157 ACAPI_Attribute_Get does not retrieve the texture status flags if the material does not have texture
40337 336 ACAPI_Element_Select can select the same element several times
40663 157 ACAPI_Element_Create creates corrupt symbol label element if invalid additional parameter handle is passed
40970 326 API_FileOpenPars->useStoredLib has no effect
41695 466 Cannot create curved dimension lines
44967 403 Passing nullptr in API_ModulData->dataHdl does not remove the module data, but makes Archicad crash at saving the plan (see ACAPI_ModulData_Store)
53331 936 Modifying an existing profile attribute does not refresh the affected profiled elements
53686 979 Cannot modify custom profile assigned to an element
53724 1140 Drawings created with ACAPI_Element_Create from an internal view do not appear until manually updated
55541 1005 Missing attribute data in Fills that contain multiple polygons (API_SymbolHatchDef->sfill_SolidFills)
55712 1140 Unable to set Fill Pen to -1 in a Text Element
58346 1146 Cannot change rendering engine with APIEnv_ChangeRenderingSetsID

 

API related bugs fixed in Archicad 9 (API version 6)

Ref. # Build Defect summary
6.1
2163 1048 ACAPI_Element_GetDefaults/ACAPI_Element_SetDefaults doesn’t transfer the link property type, it will always be ‘by Criteria’ (see ACAPI_Element_GetLinkedPropertyObjects and ACAPI_Element_SetLinkedPropertyObjects)
23795 1064 APIIo_ObjectSettingsID does not give back labeling and linked properties data (see API_ObjectSettingsPars)
24934 1052 Cannot add user data to Labels and Dimensions
25563 1206 Add-on dialogs with resID 32700 can be unwillingly resized after opening the file dialog from Add-On Manager
26051 1070 Accessing Element Sets would be more convenient with their unique IDs (see Element Set Manager)
26624 1034 Cannot create and delete Independent Details (see APIDb_NewDatabaseID and APIDb_DeleteDatabaseID)
26356 1076 ACAPI_Element_SetUserData is very slow if some elements are selected
28524 1145 ACAPI_Element_Select for a large number of elements is very slow
30177 1057 Reading a project written on the opposite platform the PlatformSign of the module data is not filled
31266 1087 ACAPI_Attribute_GetUserData returns the user data of the first attribute for non-existing attribute index rather than returning error code
31360 1144 Cannot change the libInd parameter of an object or door/window instance with ACAPI_Element_Change
31653 1385 Notification is missing after deleting an element on Section/Elevation
31672 1391 ACAPI_Interface user input functions should return the z coordinate values during input in the 3D window (see APIIo_GetPolyID and APIIo_DrawRubberLineID)
31676 1502 APIEnv_GetPreferencesID to return Images and Calculation preferences as well (see API_ImagingAndCalcPrefs)
31797 1264 Custom Settings Panels are handled incorrectly if more add-ons register tabpage for the same tool (see APIPanelCreateProc and APIPanelDestroyProc)
32315 1328 Modification time of a newly created window is 0
34125 1561 Mouse constraints cannot be set for ACAPI_Interface user input (see APIIo_SetConstraintID and APIIo_ResetConstraintID)
35545 1669 ACAPI_Element_Change changes the object’s position even if it is not set in the mask
36060 1677 Cannot detect if story indices start from 1 instead of 0 (see API_StoryInfo)
36349 1681 Creating a zone category attribute with ACAPI_Attribute_Create the zone stamp name is displayed as MISSING
36666 1740 ACAPI_Element_SetUserData does not work for element defaults
38386 1920 Modifying selection of elements having custom panel on the infobox controlled by the same add-on can crash Archicad
39081 1947 No material index returns in the iumat field of API_BodyType if the material was defined in the GDL 3D script

 

API related bugs fixed in Archicad 8.1 (API version 5)

Ref. # Build Defect summary
5.1
9261 354 Menu item icons of an add-on command are masked incorrectly in disabled state on Windows
19468 335 Unnecessary APIPalMsg_HidePalette_Begin and APIPalMsg_HidePalette_End messages are sent to API palettes at New and Reset
21179 753 Incorrect behaviour of APIIo_PetPaletteID
21547 1041 Merge File operations cannot be undone (see APIIOCommandProc)
21267 335 Nesting level of graphical input methods is limited to 4
21784 254 Line type preferences for construction elements to be displayed across stories cannot be queried (see API_LegacyPrefs)
21928 648 The net area value of a Zone (that is the area after subtracting walls, columns, etc.) cannot be queried
22117 74 ACAPI_Notify_CatchNewElement works only up to 10 element types
22118 244 Elements cannot be created on APINotify_ChangeProjectDB notification during an I/O operation
22450 471 Autosaved project does not include the stored module data
23252 584 The API_NoteType structure is not aligned correctly to 8 bytes
23280 401 ACAPI_Attribute_Get truncates the font names to 32 bytes (see API_Attr_Head)
23281 343 ACAPI_3D_GetComponent does not free the generated normal vectors, consuming memory
23595 729 ACAPI_Element_Edit ignores the elevation parameter with APIEdit_Drag and APIEdit_Rotate
23605 469 ACAPI_Element_Create miscalculates the roof thickness parameter
23691 804 Element notification sometimes gives incorrect parent indices
23762 669 Cannot append custom tabpage into subtype tool’s settings dialog (e.g. Skylight Settings)
23798 506 API_WallType->thickness1 is ignored and set to 0 at creating a trapezoid wall if the default wall is normal
23846 528 Arrow toolbox mode cannot be selected with APIEnv_SetToolBoxModeID
23995 672 Additional parameters (memo) cannot be accessed from custom settings tabpages
24213 685 Cannot be set transparent color index in API_WallType->fillBGPen
24242 699 When creating a roof with roofsides parameter containing the correct number of API_RoofSide records, ACAPI_Element_Create returns APIERR_BADPARS
24263 990 Merging ModulData does not work
24328 752 After modifying a library part, ACAPI_LibPart_Save does not updates the object instances on the floor plan
24521 862 Archicad does not send a APINotify_ChangeFloor notification when a story is deleted
24568 862 Rendering settings cannot be changed while no background picture is set
24602 862 Opening orientation (left-hand or right-hand) of doors and windows cannot be requested correctly
24932 1023 Certain parameters of the API_LabelType structure are not filled by ACAPI_Element_Get
24933 1008 Undo/Redo notifications are missing for Labels and Dimensions
25001 1081 It is possible to create additional Empty and Solid fill attributes
25568 39 Section/Elevation window of a freshly created cutplane cannot be opened with APIDo_ChangeWindowID
25722 986 Though the add-on export format is missing from Save As dialog’s popup, it is shown in the Add-On Manager Info
25939 1023 ACAPI_Element_ChangeDefaults returns with error on changing the libInd of the default window
26261 1081 API_Gable information created with ACAPI_Element_Create is not stored into the plan file
26536 1157 ACAPI_Element_GetRelations does not retrieve wrapped columns
26537 1157 ACAPI_Element_GetRelations does not find beams in certain cases
26883 1247 The local texture coordinate system was not returned correctly for separate bodies
5.2
26408 2035 Opening a file of an external file type as GDL object causes crash if the floor plan window is closed
26796 2116 At changing drwIndex or locking an element, Delete and New notifications are sent instead of APINotifyElement_Change
27149 2111 If there is no element in the marquee, ACAPI_Selection_Get returns correct count of points of the marquee but selectionInfo.marquee.coords is nullptr
27179 2123 Old UserData Conversion can mess up the undo queue
27853 2165 ACAPI_Element_ShapePrims does not send libpart hotspots (see ACAPI_LibPart_GetHotspots)
27887 2121 Cannot decide which layer combination is in effect (see API_LayerCombType)
28647 2206 After calling APIDb_ChangeGridSettingsID the Grid Snapping switch shortcut becomes unavailable
28878 2209 Label elements of a section database cannot be changed with ACAPI_Element_Change if the section window is not open
30355 2249 Cannot create Addition solid link (APISolid_Add) with ACAPI_Element_SolidLink_Create
30488 2253 The texture.status field of API_MaterialType is filled out incorrectly when requesting a material attibute defined in GDL script

 

API related bugs fixed in Archicad 8 (API version 4)

Ref. # Build Defect summary
4.2
20450 4245 ACAPI_Goodies (APIAny_GetParamValuesID, ...) function doesn’t return the value list
20614 5059 ACAPI_Environment (APIEnv_GetSpecFolder, ...) doesn’t return the application’s folder
19833 5072 ACAPI_Element_Change doesn’t take into account the ‘Window/Door Height change affects Sill/Head’ option in the preferences
20383 5072 The fill index and the thickness of a wall cannot be changed simultaneously with ACAPI_Element_Change
20757 4257 ACAPI_Environment (APIEnv_CheckDongle, ...) functionality was missing
20820 5129 The location of the texture file linked to a material was not correct in some cases
20844 5045 CSG links could not be reached through the API
17685 5219 ACAP_DLL was not available
20153 5278 Old userdata (coming from Archicad 7.0) attached to elements couldn’t be converted
21270 5304 ACAPI_LibPart_Search didn’t find the library part in some cases, when only the name and the type were given
21273 5313 APINotify_New notification came before the “Load Libraries…” dialog, if the user opened a plan file directly from the Startup dialog
21261 5320 The height of the topmost story could not be retrieved
21268 5360 ACAPI_Goodies (APIAny_ConvertPictureID, ...) didn’t work well if you wanted to convert a GIF to a BMP
21541 5407 No notifications were posted for tool changes
21662 5420 ACAPI_Selection_Get doesn’t return the neigs for window and door markers
21699 5427 ACAPI_Element_Create didn’t work for objects in Section windows
21719 5444 ACAPI_Element_GetRelations returns bad polygon ids for niches
21741 5444 ACAPI_Element_GetDefaults doesn’t return the additional parameters in the element memo for Windows/Doors
21753 5444 ACAPI_Element_Create didn’t check roof parameters correctly
21754 5444 ACAPI_Element_Create didn’t work for rooms
21755 5444 ACAPI_Environment (APIEnv_ChangeStorySettings, ...) didn’t work correctly for stories above 0.
21841 5474 ACAPI_Element_Create didn’t work for polygon walls.
21922 5488 ACAPI_Attribute_Get doesn’t return the name of materials defined in GDL scripts
21965 5502 ACAPI_Automate (APIDo_SaveID, ...) didn’t work for objects on Macintosh
22142 5551 ACAPI_ModulData_Get return the data version in the platformSign field
22148 5551 ACAPI_ElementSet_Delete fails with APIERR_NOTMINE if you want to delete element sets created earlier by your add-on
4.3
17677 6178 Cannot create picture element in API list window
21587 6022 ACAPI_Goodies (APIAny_GetTextLineLength, ...) doesn’t use the font index correctly
21665 6058 ACAPI_Element_Create returns with APIERR_BADPARS if you want to create an object with reference to a missing library part
21750 6058 ACAPI_LibPart_GetSect_ParamDef fails if its second parameter (the additional parameters) is nullptr
21752 6058 ACAPI_LibPart_Create doesn’t work with an empty library part location
21779 6022 ‘User defined sharp’ is missing from the options for smoothing ridges in meshes
21856 6058 Label arrow data is lost in many ACAPI_Element_ functions, if the label is a symbol label
21877 6173 ACAPI_Element_GetQuantities works on plan window only, it should work for drawing elements in all 2D windows
21970 6058 Cutplane and detail marker objects cannot be reached via the API (see ACAPI_Element_CreateExt, ACAPI_Element_ChangeExt)
21981 6121 Project Navigator data cannot be accessed (see Project Navigator Environment)
22021 6167 Calling Rebuild from window change notification while switching to the 3D model window causes crash
22055 6058 ACAPI_Interface (APIIo_Getxxx, ...) functions doesn’t handle the neig filter correctly
22222 5596 The cutPlShow field was missing from cutplane element structure
22242 6058 Some parameters were missing from the defaults for detail elements
22250 6058 ACAPI_Element_ChangeDefaults cannot set an object on transparent node as the plain object default
22252 6058 ‘Zero depth’ was missing from the options of horizontal range in cutplane elements
22334 6168 ACAPI_Element_Create threats incorrectly the rotated or mirrored pictures
22429 6234 ACAPI_Element_ChangeParameters does not work for API_DetailType
22457 6162 Changes of the data of a custom settings panel are not transmitted into the selected elements
22530 6172 When using custom tabpage in a settings dialog the element selection goes wrong
22535 6110 The “Create New Object…” popup does not appear in the settings dialog of an External Symbol
22957 6234 ACAPI_Element_ChangeParameters does not work for API_PolyLineType
22995 6173 ACAPI_Element_GetPropertyObjects works on plan window only, it should work for drawing elements in all 2D windows
23074 5663 ACAPI_OpenUndoableSession can cause crash with multibyte string parameter passed
23113 5665 Modeless palettes can be put on even in PlotMaker, because the add-on cannot request if the application is running in background mode
23378 5668 ACAPI_Element_Get3DInfo fails when called from 3D window
23899 6313 APIDo_SaveAsModuleFileID expects IO::Location pointer instead of CIO::Location*