Library Part Manager


To have an overview what the Library Parts are, and how they fit into the entire database please refer to the LibPart Overview chapter.

In these papers only the handler functions are explained in full details.

 

Handler Functions

All of the Library Part handler functions begins with the ACAPI_LibPart_ prefix. This function family gives support to query the Library Part database, to modify the existing items, and also to create new instances. Refer to the functions below to have details on these topics.

The following functions work on the actual Library Part registration:

ACAPI_LibPart_GetNum
ACAPI_LibPart_Search
ACAPI_LibPart_Register
ACAPI_LibPart_RegisterAll  18

The following functions are available to get data of a registered Library Part:

ACAPI_LibPart_Get
ACAPI_LibPart_GetSectionList
ACAPI_LibPart_GetSection
ACAPI_LibPart_GetParams
ACAPI_LibPart_GetDetails
ACAPI_LibPart_ShapePrims
ACAPI_LibPart_GetHotspots  5.2

The following functions are available to modify data of a registered Library Part:

ACAPI_LibPart_UpdateSection
ACAPI_LibPart_SetDetails_ParamDef

The following functions are available to create and register a new Library Part:

ACAPI_LibPart_Create
ACAPI_LibPart_AddSection
ACAPI_LibPart_NewSection
ACAPI_LibPart_WriteSection
ACAPI_LibPart_EndSection
ACAPI_LibPart_Save
ACAPI_LibPart_SetUpSect_2DDrawHdl
ACAPI_LibPart_GetSect_2DDrawHdl
ACAPI_LibPart_GetSect_ParamDef
Notes

These functions work on the registered Library Parts only, in the manner that they access the internal data sections of the Library Part; but they do not manipulate on the active library folders itself. To get information on this operations refer to the ACAPI_Environment function.

 

Auxiliary Functions Related to Library Parts

The following functions are available to support accessing the additional parameters of a Library Part:

APIAny_OpenParametersID
APIAny_GetParamValuesID
APIAny_ChangeAParameterID
APIAny_GetActParametersID
APIAny_CloseParametersID

The following functions are available to handle subtypes and Library Part Unique IDs:

APIAny_GetBuiltInLibpartUnIdID
APIAny_CheckLibPartSubtypeOfID
APIAny_CompareLibPartUniqueIdsID
APIAny_GetElemCreatorToolUnIdID
APIAny_SetEmptyHoleUnIdID
APIAny_GetElemLibPartUnIdID