Listing Manager


To have an overview what the listing database are, and how they fit into the entire database please read this document carefully.

Only the handler functions are explained in full detail; the Archicad Reference Manual contains more information on the listing databases.

 

Handler functions

All of the listing data handler function begin with the ACAPI_ListData_ prefix. This function family gives support to query the listing database. Modifications are not supported in this version of the API; you can’t change the listing database. Refer to the functions below to have details on these topics.

The following functions work on the different listing database sets:

ACAPI_ListData_GetSetNum
ACAPI_ListData_GetSet

The following functions work on the internal items of a given listing database:

ACAPI_ListData_GetNum
ACAPI_ListData_Get
ACAPI_ListData_GetLocal
ACAPI_ListData_Search

 

General Error Codes

APIERR_BADID

invalid reference;
the component type is invalid

APIERR_BADINDEX

invalid reference;
the component index is out of range

APIERR_DELETED

invalid reference;
the body does not exist in the database (deleted)