The API provides a function set for platform independent resource operations, related to string resources.
By general programmers put all the strings into resources and load them upon request. The GRC format and compiler supports two type of string lists. The ‘STRf’ resource represents fix strings, i.e. which does not require localization. The ‘STR#’ resource type represents strings which require localization in different language versions of the add-on.
The following functions helps you load such resources from the resource map.
ACAPI_Resource_GetFixStr
ACAPI_Resource_GetLocStr
ACAPI_Resource_GetLocUStr
Important:
Each time when loading any type of resources (strings, dialogs, icons etc.) you will have to identify the specific resource module from which you need the resource. Use the return value of ACAPI_GetOwnResModule function wherever a reference to the add-on’s own resource module is needed. The resource module identifier is not fix, it changes every time when add-on is loaded or reloaded to the memory.
ACAPI_GetOwnResModule