RoomReductionPolyProc

Callback function to get reduction polygons of a room.

    typedef void  RoomReductionPolyProc (
        const API_RoomReductionPolyType*     roomRed
    );

 

Parameters

roomRed
[out] Data of a room reduction polygon.

 

Remarks

You should implement this function and pass its address to the APIDb_RoomReductionsID function as a callback function if you want Archicad to send the polygons which reduce a room area.

Archicad will send you all the area (polygon) which reduce the room area. Many information is provided, the polygon itself, the area, the reduction percent, and the type of the parent element. See API_RoomReductionPolyType for more details. Since Archicad 18, the first dummy element has been removed.

 

Example

See the example of APIDb_RoomReductionsID function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Callback.h

 

See Also

API_RoomReductionPolyType,
APIDb_RoomReductionsID,
API Functions