RubberLineInfoProc

Callback function for custom feedback drawing.

    typedef void  RubberLineInfoProc (
        const API_RubberLineInfo*     info
    );

 

Parameters

info
Information on the actual input state.

 

Remarks

You should implement this function if you have to give graphical feedback for the input operation invoked from your API tool add-on. This callback routine should be passed as a parameter when calling the APIIo_GetPointID, APIIo_GetLineID and APIIo_GetArcID interface functions. During the input process your procedure is called repeatedly as the mouse moves. In the info parameter you get the actual mouse coordinate and the current drawing phase. Call the APIIo_DrawRubberLineID interface function to draw your rubber lines. The lines are drawn in XOR mode, therefore you can use the same code for both the drawing and erasing phases when calling back.

6.1  From Archicad 9 the z coordinates are retrieved even when the input plane has not been defined. The height value can be non-zero if the cursor is on one of the neigs of a three-dimensional element, or gravity method is switched on for the element type the cursor is currently cruising above.

 

Example

See APIIo_DrawRubberLineID for example of using the rubber line drawing callback function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Callback.h

 

See Also

API_RubberLineType
API_RubberLineInfo
APIIo_DrawRubberLineID
ACAPI_Interface
API Functions