SaveProc

Callback function to save document in the new registered publish format.

    typedef GSErrCode  SaveProc (
        API_SaveMethod     method
        const char*        path
        API_UserData*      userData
        GS::UniString*     reportStr

    );

 

Parameters

method

Possible values

Save2DProc

SaveSectionProc

Save3DProc

SaveRenderingProc

SaveTextProc

SaveReportProc

SaveDrawProc

SaveLayoutProc

SaveMovie3DProc

SaveMovieRenderingProc

SaveDetailDrawingProc

SaveIESProc

SaveDocumentFrom3DProc

path
The path where to save the published file
userData
The userData contains the save options given by the Add-On.
reportStr
The reportStr be set for an error message if the publishing failed.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 22 or later
Header: APIdefs_Callback.h

 

See Also

API Functions